Project

General

Profile

Bug #3850

Boethiah's voice is distorted underwater

Added by Miroslav Remák 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
Sound/Other Media
Target version:
Start date:
04/30/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

Boethiah's voice should not be affected underwater. Technically, it is the player who is speaking:

Player->Say "Vo\Misc\DA_BoethiahIntro1.wav", "What do you want with me, mortal? My shrine is in ruins, my priests have forgotten me. Will you rebuild my shrine, mortal? Restore it in all its glory? Accomplish this, and I will reward you. You will be the bearer of Goldbrand, my sword of legend. There is one who can help you do this for me. Listen...." 

Vanilla (unlike OpenMW) doesn't seem to apply environmental effects to player's voice.

See also: https://forum.openmw.org/viewtopic.php?f=2&t=4268

Associated revisions

Revision d24bcbac (diff)
Added by Miroslav Remák 7 months ago

Do not apply underwater effects to player's voice (Fixes #3850)

History

#1 Updated by R. D. 7 months ago

They aren't applied to NPC voices, either. Make an NPC "startcombat" with you while you're under the water, and you'll hear it without any effect on it.

This would also fix https://bugs.openmw.org/issues/3382.

#2 Updated by R. D. 7 months ago

Underwater effects are applied to creature voices.

#3 Updated by R. D. 7 months ago

In fact, really this is a duplicate of https://bugs.openmw.org/issues/3382, but since you're already working on this one, I close the other one. I'll make a new report about NPCs speaking in water.

#4 Updated by Alexei Dobrohotov 7 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF