Project

General

Profile

Bug #3793

OpenMW tries to animate animated references even when they are disabled

Added by Luke Driscoll 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Animation
Target version:
Start date:
03/19/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Windows
Severity:
Normal

Description

With ROHT I was getting constant error messages in Balmora and Aldruhn:

warning Objects::playanimationgroup: unable to find roht_mg_aldruhntelvbanner
warning Objects::playanimationgroup: unable to find roht_mg_balmoratelvbanner

I only had ROHT and Tribunal and Bloodmoon activated. The errors keep going until I leave the cell, and cause fps drop.
I redownloaded and installed ROHT again, but it didn't fix anything.

openmw.log View (36.6 KB) Luke Driscoll, 03/19/2017 11:17 PM

Associated revisions

Revision 143ee387 (diff)
Added by R. D. 5 months ago

Add enabled check to animation script commands

(Fixes #3793)

History

#1 Updated by R. D. 5 months ago

  • Status changed from New to Resolved

Confirmed. The problem is that there is a disabled banner that has a script to play animations. There doesn't seem to be any check in OpenMW that something is enabled before attempting to play animation commands.

After adding such a check the problem seems to be resolved. I'll submit a PR.

#2 Updated by Alexei Dobrohotov 5 months ago

  • Category set to Animation
  • Assignee set to R. D.
  • Target version set to openmw-0.43

#3 Updated by Alexei Dobrohotov 5 months ago

  • Subject changed from Rise of House Telvanni Errors to OpenMW tries to animate animated references even when they are disabled

#4 Updated by R. D. 5 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF