Project

General

Profile

Bug #3787

Script commands in result box for voiced dialogue are ignored

Added by Andrei Kortunov 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
03/13/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

Script commands in result textbox (Character->Dialogue->Voice records in TES CS) seems to be ignored, but Character->Dialogue->Greeting records works as expected.
A number of plugins uses voice result-box feature (e.g. Morrowind Economy Adjuster).

Morrowind version: clean russian Morrowind+Tribunal+Bloodmoon without any other plugins installed.

I created a test plugin to reproduce this bug (sorry, but I have only a russian version of Morrowind). ResultBoxTest.esp contains two MessageBoxes:
1) On NPC voice greeting (ignored)
2) On dialog start (works in current version of OpenMW)

Expected results: both MessageBoxes work
Actual result: only second MessageBox works

ResultBoxTest.esp - Test plugin to reproduce a bug (9.3 KB) Andrei Kortunov, 03/13/2017 04:32 PM

openmw.log View - OpenMW log file (1.99 KB) Andrei Kortunov, 03/13/2017 04:39 PM

Screenshot_20170313_194455.png View - TES CS screenshot (105 KB) Andrei Kortunov, 03/13/2017 04:48 PM

ResultBoxTest2.ESP (5.67 KB) R. D., 03/23/2017 01:47 PM

Associated revisions

Revision 60c67bc3 (diff)
Added by R. D. 5 months ago

Run scripts for voiced dialogue

(Fixes #3787)

History

#1 Updated by R. D. 6 months ago

  • File ResultBoxTest2.ESP added
  • Subject changed from Script commands in result box seems to be ignored to Script commands in result box for voiced dialogue is ignored
  • Status changed from New to Confirmed

Confirmed.

By the way, with your .esp I get a warning but can load the original game (didn't try it in OpenMW), but I can't open a greeting dialogue to test the script command in it because the greeting is empty. I made an .esp like yours but with wording added to the greeting and I confirmed the bug this way. I'll attach the .esp I made (ResultBoxTest2).

#2 Updated by R. D. 6 months ago

  • Subject changed from Script commands in result box for voiced dialogue is ignored to Script commands in result box for voiced dialogue are ignored

#3 Updated by Marc Zinnschlag 6 months ago

  • Target version changed from openmw-0.42 to openmw-0.43

#4 Updated by Alexei Dobrohotov 5 months ago

  • Status changed from Confirmed to Resolved
  • Assignee set to R. D.

#5 Updated by R. D. 5 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF