Project

General

Profile

Bug #3720

Death counter not cleaned of non-existing IDs when loading a game

Added by Amenophis . 9 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Save/Load
Target version:
Start date:
01/10/2017
% Done:

100%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

I played TR 16.09.1 and did some quests. After TR have updated to 16.12, I disabled the old version, loaded the save and created a new one. After that I ticked the version 16.12 and loaded the cleaned save.

What I expected is that the quests and it’s states would reset and I could do everything again.

Redid the Quest “Trouble in Ranyon-ruhn: Daggers and Chains” (TR_m1_RR_MQ_5) where I have to make a deal with a slaver. When talking with the Dres slaver he gave me an answer that comes after paying him or if the slaves are dead.

My fidings are: both slaves (TR_m1_q_ArgonianHitman1 and TR_m1_q_ArgonianHitman2) are alive in this save but the engine says they are already dead (verified with GetDeadCount for TR_m1_q_ArgonianHitman1 and TR_m1_q_ArgonianHitman2).

Since I’ve already killed them with this character before and started anew my conclusions are that the cleaning process resets the Journal indexes but not the life states of them.

What I can do to reset them to their alive state?

Attached the save.
Linux Mint 18.1 64 bits
0.41.0+git201701101521~ubuntu16.04.1

Before_talk_with_the_slaver_and_slaves.omwsave.7z - Talk with them. Verify their alive state. (4.59 MB) Amenophis ., 01/10/2017 11:06 PM

History

#1 Updated by scrawl . about 1 month ago

  • Category set to Save/Load
  • Status changed from New to Confirmed

#2 Updated by scrawl . about 1 month ago

  • Subject changed from After cleaning a save of a mod and starting again the new NPCs don’t reset their state. to Death counter not cleaned of non-existing IDs when loading a game
  • Status changed from Confirmed to Closed
  • Assignee set to AnyOldName 3
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

Also available in: Atom PDF