Project

General

Profile

Bug #3708

Controllers broken on macOS

Added by Nikolay Kasyanov 9 months ago. Updated 12 days ago.

Status:
Confirmed
Priority:
Normal
Category:
Input
Target version:
Start date:
01/05/2017
% Done:

100%

Reproducibility:
Always
Operating system:
MacOS
Severity:
Minor

Description

Here's the original report: https://www.reddit.com/r/OpenMW/comments/5gj7o8/controller_problems/

I believe this can be the culprit: https://github.com/gabomdq/SDL_GameControllerDB/issues/110 because I'm using SDL 2.0.5 for macOS builds at the moment.
A patch to support old GUID format is already in upstream of SDL, but isn't yet released.

Also, I noticed we haven't been updating gamecontrollerdb.txt from upstream for 6 month.


Related issues

Copied from OpenMW - Bug #3964: Xbox One controller not functional on a Mac Rejected 07/22/2017

History

#1 Updated by Nikolay Kasyanov 8 months ago

  • Status changed from New to In Progress

#2 Updated by Nikolay Kasyanov 8 months ago

  • Status changed from In Progress to Feedback needed
  • % Done changed from 0 to 50

#4 Updated by Nikolay Kasyanov 7 months ago

  • Status changed from Feedback needed to Resolved

Since I'm not getting any feedback, let's resolve it and see what happens.

#5 Updated by Nikolay Kasyanov 7 months ago

  • % Done changed from 50 to 100

#6 Updated by Marc Zinnschlag 5 months ago

  • Target version changed from openmw-0.42 to openmw-0.43

#7 Updated by Alexei Dobrohotov 5 months ago

Current status?

#8 Updated by Nikolay Kasyanov 5 months ago

It's supposed to be fixed, but I haven't got any confirmations so far.

#9 Updated by Alexei Dobrohotov 3 months ago

  • Target version changed from openmw-0.43 to openmw-1.0

#10 Updated by scrawl . 14 days ago

  • Subject changed from Invalid right stick axis mapping for PS3 controller on macOS to Controllers broken on macOS
  • Status changed from Resolved to Confirmed

Making this the master issue for controller problems on macOS, of which there are new reports.

#11 Updated by Will Herrmann 13 days ago

  • Reproducibility changed from Have not tried to Always

Now that this is the master issue for controller problems on macOS, I'll mention in this issue that my Xbox One bluetooth controller (with the default drivers shipping with macOS) does not work in OpenMW. I also pulled out a USB Logitech Rumblepad 2 and that one doesn't work either. This happens both with code I build from source and the 2017-09-09 nightly.

Several people have pointed out that our controller mappings come from this repository. Unfortunately, there haven't been any accepted pull requests since February. The developer is active on Twitter, so perhaps someone is interested in poking him (I don't have one myself). Otherwise, we may have to explore forking the repository in order to fix our issues.

#12 Updated by Will Herrmann 13 days ago

  • Copied from Bug #3964: Xbox One controller not functional on a Mac added

#13 Updated by scrawl . 12 days ago

This happens both with code I build from source

How did you build? With what version of SDL? If you use SDL 2.0.5, you have to use the patch from comment #3.

#14 Updated by Will Herrmann 12 days ago

I mistyped in the last message: this happens both with the latest nightly build (which already has this patch installed, no?) and when I build on my own. I am using 2.0.5 to build locally, but also pointing to the OpenMW-mac-deps, so I believe I have the patch already. If that's not the case, let me know.

Also available in: Atom PDF