Project

General

Profile

Bug #3696

Newlines are accompanied by empty rectangle glyph in dialogs

Added by Mark Karpov over 1 year ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Dialogue
Target version:
Start date:
12/28/2016
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Here is a screenshot from this http://en.uesp.net/wiki/Morrowind:Pilgrimage_to_Mount_Kand quest. Note the strange characters displayed where text contains newline characters. My OS setup is English, encoding UTF-8, Arch Linux. Morrowind is in English, default. All other text in dialogs is displayed correctly.

screenshot005.png View (1.95 MB) Mark Karpov, 12/28/2016 07:26 PM

Associated revisions

Revision 4f190bf7 (diff)
Added by Andrei Kortunov 5 months ago

Do not show carriage return characters (bug #3696)

History

#1 Updated by Miroslav Remák over 1 year ago

I can't see the glyphs with the standard bitmap font. It's probably the carriage return characters, though. I don't think we're throwing them out.

#2 Updated by Miroslav Remák over 1 year ago

  • Category set to Dialogue
  • Status changed from New to Confirmed
  • Target version set to openmw-0.42
  • Reproducibility changed from Have not tried to Always

#4 Updated by Alexei Dobrohotov about 1 year ago

  • Subject changed from Newlines are accompanied by empy rectangle glyph in dialogs to Newlines are accompanied by empty rectangle glyph in dialogs

#5 Updated by Marc Zinnschlag about 1 year ago

  • Target version changed from openmw-0.42 to openmw-0.43

#6 Updated by Alexei Dobrohotov 7 months ago

  • Target version changed from openmw-0.43 to openmw-1.0
  • Operating system changed from Linux to Other

#7 Updated by Andrei Kortunov 5 months ago

Looks like the Newline character glyph is missing in the Pelagiad font, so OpenMW uses the default glyph from the \0 character (rectangle glyph).
I doubt it can be fixed from the OpenMW side.

And is it really the 1.0 blocker?

#8 Updated by Miroslav Remák 5 months ago

Andrei Kortunov wrote:

I doubt it can be fixed from the OpenMW side.

As I said, what we could do is throw out the '\r' characters (e.g. in TypesetBookImpl::Typesetter::writeImpl).

#9 Updated by Alexei Dobrohotov 5 months ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version changed from openmw-1.0 to openmw-0.44
  • % Done changed from 0 to 100

#10 Updated by Andrei Kortunov 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF