Project

General

Profile

Bug #3664

Combat music does not start in dialogue

Added by August Avatar over 1 year ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Sound/Other Media
Target version:
Start date:
12/15/2016
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Morrowind features numerous quests in which NPCs can become hostile to you in dialogue. All topics besides "Goodbye" will become greyed out, and in vanilla, this is when the exploration music ends and the combat music begins. In OpenMW the music will not transition until you have exited the dialogue window completely.

This does not apply to NPCs you've taunted into becoming hostile - in that case, the behavior is the same as in OpenMW. So it's not fully consistent in the vanilla game.

Tested with Foryn Gilnith in Seyda Neen (quest: "Death of a Taxman") and Fjol outside Hla Oad (quest: "Fjol the Outlaw")

Associated revisions

Revision b9d9660e (diff)
Added by Andrei Kortunov 5 months ago

Update music state in the menu mode (bug #3664)

History

#1 Updated by Marc Zinnschlag about 1 year ago

  • Category set to Sound/Other Media
  • Target version changed from openmw-0.42 to openmw-0.43

#2 Updated by Andrei Kortunov 10 months ago

Which behaviour would be more correct: a vanilla one, an OpenMW one, or starting a combat music in both cases?

#3 Updated by Andrei Kortunov 10 months ago

Note: taunt uses "Should Attack" editor function, but most of topics use "StartCombat Player" script function.

If we want vanilla behaviour, we can change music in "StartCombat" and "StopCombat" handlers.

#4 Updated by Andrei Kortunov 9 months ago

taunt uses "Should Attack" editor function

Actally, successfull taunt just increases NPC Fight rating. The battle in this case starts after you close dialogue window.
With "StartCombat" battle starts immediately, but we update a music state in a different place.

#5 Updated by Andrei Kortunov 9 months ago

We can add, of cource

mActors.update(0, false);

check to MechanicsManager::startCombat, but it looks like overkill.

IMO, we can split a music transition from Actors::update() and update music state separately.

#6 Updated by Andrei Kortunov 9 months ago

  • Status changed from New to Confirmed
  • Operating system changed from Windows to Other

#7 Updated by scrawl . 7 months ago

  • Target version changed from openmw-0.43 to openmw-1.0

#8 Updated by Andrei Kortunov 5 months ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version changed from openmw-1.0 to openmw-0.44
  • % Done changed from 0 to 100

#9 Updated by Alexei Dobrohotov 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF