Project

General

Profile

Bug #3618

Myar Aranath total conversion can't be started due to capital-case extension of the master file

Added by Flynn Moneaux over 1 year ago. Updated 20 days ago.

Status:
Closed
Priority:
Normal
Category:
Launcher
Target version:
Start date:
11/07/2016
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

System: Windows 10. GoG version of Morrowind, english.
Expected behaviour: After adding a Morrowind installation with a total conversion to the launcher, I can select its data files and play the total conversion.
Actual behaviour: After adding a Morrowind installation with a total conversion to the launcher, selecting the data files and trying to start the game gives the error: "No game file selected: You don't have a game file selected. OpenMW will not start without a game file selected."

After installing OpenMW 0.40, I tried running the total conversion "Myar Aranath" 1). I selected the "ma_script_base.ESM" as master file and all other ESM/ESP files 2) for this modification in the OpenMW launcher. After this, I pressed the play button but only got the error message "No game file selected: You don't have a game file selected. OpenMW will not start without a game file selected."
I tried running the Installation Wizard and importing Morrowind settings several times. I deleted the OpenMW folder and tried running the Installation Wizard again. But I had no success in doing so.
OpenMW 0.39 shows the same behaviour as OpenMW 0.40: Same error message.
It works in OpenMW0.38.

1) http://sureai.net/games/myararanath/?lang=en
2) MA_RoK_1.00.ESM, , MA_Patch_1.00to1.31.esp, MA_Patch_1.31to1.32.esp, MA_Fehlerkorrektur.esp

Associated revisions

Revision be542507 (diff)
Added by Alexei Dobrohotov 25 days ago

Make hasMaster() behavior consistent with isGameFile() (fixes #3618)

History

#1 Updated by Flynn Moneaux over 1 year ago

I managed to start Myar Aranath on OpenMW 0.40.

The solution/workaround:
  1. In the Morrowind launcher, add (at least) the Morrowind.ESM.
  2. In the OpenMW launcher, run the Settings Importer
  3. In the data files tab in the OpenMW launcher, there is now the ma_script_base.ESM selected. All other ESP files are visible, too.
  4. Select the files needed for Myar Aranath.
  5. Click play.

If you change the master file to Morrowind.ESM and back, it will show the error message "No game file selected: You don't have a game file selected. OpenMW will not start without a game file selected."

This behaviour is in OpenMW 0.38 and 0.40.

#2 Updated by Flynn Moneaux over 1 year ago

And now I tried with the german Morrowind for a more consistent feeling as the mod is german, and I can't manage to get past the error "No game file selected" this time.
Choosing the Morrowind.esm in the Morrowind launcher and using this as profile only starts Morrowind, not Myar Aranath.

#3 Updated by Miroslav Remák over 1 year ago

Try decapitalizing the extensions (.ESM -> .esm).

#4 Updated by Miroslav Remák over 1 year ago

  • Status changed from New to Feedback needed

#5 Updated by Alexei Dobrohotov 25 days ago

  • Subject changed from Total conversion with own ESM can't be started since OpenMW 0.39, Error "No game file selected" to Myar Aranath total conversion can't be started due to capital-case extension of the master file
  • Status changed from Feedback needed to Resolved
  • Assignee set to Alexei Dobrohotov
  • Target version set to openmw-0.44
  • Operating system changed from Windows to Other

What Miroslav suggested works. Looking at the code, it seems this happens because hasMaster() is not case-insensitive (Qt contains() function used there for deducting if the file is a game file is case-sensitive by default), unlike isGameFile() function.

#6 Updated by Alexei Dobrohotov 20 days ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF