Project

General

Profile

Bug #3528

Disposing of corpses breaks quests

Added by W. Pepper Marts about 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
High
Category:
Game Mechanics
Target version:
Start date:
09/04/2016
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

This bug occurs on Windows 10 (64-bit), OpenMW version 0.40.0 (64-bit), Steam Version, English, with only expansions installed and selected.

During the quest Larrius Varro Tells a Little Story, if the player disposes of any of the corpses of the Camonna Tong members in the Council Club the quest giver will no longer recognize the quest as being complete after the "blood bath". If the player does not dispose of any corpses it works as intended. In vanilla morrowind, the quest can be completed even after disposing of one or more of their corpses.

The same bug does not appear to effect Morag Tong assassination quests, perhaps due to there being a quest stage update on the death of the NPC, not a check for dead NPCS and no related quest stage for their deaths prior to returning to the quest giver.


Related issues

Duplicated by OpenMW - Bug #3513: GetDeadCount doesn't always get incremented Rejected 08/30/2016
Duplicated by OpenMW - Bug #3825: Spriggans in Bloodmoon can be disposed before they are "truly" dead Rejected 04/14/2017
Duplicated by OpenMW - Bug #3969: Hunger in the Sarano Tomb quest can't be completed Rejected 07/25/2017

Associated revisions

Revision dd919b9f (diff)
Added by Andrei Kortunov 3 months ago

Do not allow to loot fighting actors during death animation (bug #3528)

Revision 26113770
Added by scrawl . 3 months ago

Merge pull request #1350 from akortunov/deathanimationfix

Do not allow to loot fighting actors during death animation (bug #3528)

History

#1 Updated by scrawl . about 1 year ago

  • Related to Bug #3513: GetDeadCount doesn't always get incremented added

#2 Updated by scrawl . about 1 year ago

Probably a duplicate of #3513

#3 Updated by scrawl . about 1 year ago

Does it work if you wait for the NPC to finish their death animation before disposing of the corpse?

#4 Updated by W. Pepper Marts about 1 year ago

Edit: I can replicate this on an earlier save, but not on a new character. Perhaps something else is at fault. Apologies.

#5 Updated by August Avatar about 1 year ago

Vanilla Morrowind doesn't allow you to loot corpses before the death animation is finished anyway, to my knowledge. Shouldn't OpenMW replicate this behavior?

#6 Updated by Miroslav Remák about 1 year ago

This issue also plagues vanilla Morrowind. Disposing before the death animation finishes prevents the death event from occurring (just like in OpenMW). That said, I do think it should be fixed.

Vanilla Morrowind doesn't allow you to loot corpses before the death animation is finished anyway, to my knowledge.

That's not true.

Shouldn't OpenMW replicate this behavior?

Such behavior could potentially break mannequin mods that utilize SkipAnim on corpses.

#7 Updated by August Avatar about 1 year ago

Vanilla Morrowind doesn't allow you to loot corpses before the death animation is finished anyway, to my knowledge.

That's not true.

Well, I'm stumped. After testing a new game in vanilla Morrowind with no plugins whatsoever, even mashing the space bar left me unable to interact with any corpses until the animation had finished. Now I don't know what to think.

#8 Updated by Amenophis . about 1 year ago

August Avatar wrote:

Vanilla Morrowind doesn't allow you to loot corpses before the death animation is finished anyway, to my knowledge.

That's not true.

Well, I'm stumped. After testing a new game in vanilla Morrowind with no plugins whatsoever, even mashing the space bar left me unable to interact with any corpses until the animation had finished. Now I don't know what to think.

What you saw is one of the Beta Patches of MCP 2.3:

__Actors are not fully treated as dead until their death animation is complete and they can no longer move. The final processing of an actor includes script triggers. This fix prevents a corpse from being disposed until all game mechanics on the actor are resolved.

Fixes quest issues triggering OnMurder and OnDeath flags, and clean expiry of some spell effects.__

#9 Updated by August Avatar about 1 year ago

Amenophis . wrote:

What you saw is one of the Beta Patches of MCP 2.3:

__Actors are not fully treated as dead until their death animation is complete and they can no longer move. The final processing of an actor includes script triggers. This fix prevents a corpse from being disposed until all game mechanics on the actor are resolved.

Fixes quest issues triggering OnMurder and OnDeath flags, and clean expiry of some spell effects.__

What's mystifying about it is that I tested with my unmodded GOG copy of Morrowind, which had no MCP applied! I even confimed via the MCP showcase add-on that the vanilla engine bugs were present. Furthermore, the only version of MCP I've ever installed (for my Steam copy) was 2.1.

Regardless, I'll take it that this is definitely not the behavior seen in other people's copies of vanilla Morrowind. Sorry for the digression.

#10 Updated by Miroslav Remák about 1 year ago

August Avatar wrote:

What's mystifying about it is that I tested with my unmodded GOG copy of Morrowind, which had no MCP applied! I even confimed via the MCP showcase add-on that the vanilla engine bugs were present. Furthermore, the only version of MCP I've ever installed (for my Steam copy) was 2.1.

Really strange. I can't reproduce your behavior with a freshly installed GOG version.

#11 Updated by scrawl . about 1 year ago

I'm pretty sure I don't have MCP and I see the following:

  • actor that was in combat with the player prior to dying: can't activate/loot until the death animation finishes
  • friendly actor dying (e.g. killed with "sethealth 0" console command): can activate/loot during the death animation

#12 Updated by Miroslav Remák about 1 year ago

Oops, that's what I get for being lazy to kill properly and using "sethealth 0" instead. :P

Thanks for looking into this, Jannik.

Jannik Heller wrote:

  • actor that was in combat with the player prior to dying: can't activate/loot until the death animation finishes

Merely being in combat is enough (doesn't have to be with the player). Other than that I can confirm this - using StopCombat during the death animation allows me to loot the corpse again.

#13 Updated by August Avatar about 1 year ago

Hooray, I'm not crazy after all :)

After further testing, even an instant sneak kill will initiate combat (including battle music, etc) from the moment you land the blow until the death animation is completed. Should you attempt to activate them in this brief window you will get the message "This character is in combat."

I now presume MCP's fix is specifically for those exceptions involving console commands, unless there's something else to this.

#14 Updated by R. D. about 1 year ago

The MCP fix may be for followers/summons. I just tested and in the original engine if you kill them within the number of hits needed to make them go into combat with you, you can loot their body while they are playing the death animation.

#15 Updated by Amenophis . about 1 year ago

MCP fixes the death of Umbra, too ( http://www.uesp.net/wiki/Morrowind:Umbra_(quest). Some have reported that sometimes his death doesn't update the quest.

#16 Updated by scrawl . 12 months ago

  • Subject changed from Disposing of corpses breaks the quest "Larrius Varro Tells a Little Story" to Disposing of corpses breaks quests
  • Status changed from New to Confirmed
  • Priority changed from Normal to High
  • Target version set to openmw-0.41

#17 Updated by Miroslav Remák 12 months ago

  • Target version changed from openmw-0.41 to openmw-0.42

#18 Updated by scrawl . 9 months ago

  • Related to deleted (Bug #3513: GetDeadCount doesn't always get incremented)

#19 Updated by scrawl . 9 months ago

  • Duplicated by Bug #3513: GetDeadCount doesn't always get incremented added

#20 Updated by scrawl . 9 months ago

  • Target version changed from openmw-0.42 to openmw-future

#21 Updated by scrawl . 9 months ago

  • Target version changed from openmw-future to openmw-1.0

#22 Updated by Miroslav Remák 7 months ago

  • Duplicated by Bug #3825: Spriggans in Bloodmoon can be disposed before they are "truly" dead added

#23 Updated by Alexei Dobrohotov 4 months ago

  • Duplicated by Bug #3969: Hunger in the Sarano Tomb quest can't be completed added

#24 Updated by Andrei Kortunov 4 months ago

actor that was in combat with the player prior to dying: can't activate/loot until the death animation finishes

Not surprising at all: fighting actors activation (even if they are friendly) is blocked until end of death animation. GetDeadCount will be updated in this case.

If you attack and instakill a non-follower actor, Morrowind will treat this actor as fighting and will block activation. GetDeadCount will be updated in this case.

The followers behaviour is bugged - you can kill a follower with 3 hits and can loot the follower during death animation, because he is not fighting and activation is not blocked. You can use this trick also for actors killed via script.

#25 Updated by Alexei Dobrohotov 4 months ago

  • Category set to 8
  • Status changed from Confirmed to Resolved
  • Target version changed from openmw-1.0 to openmw-0.43
  • % Done changed from 0 to 100

#26 Updated by Alexei Dobrohotov 4 months ago

  • Assignee set to Andrei Kortunov

#27 Updated by Attila Mika 3 months ago

Is this issue really resolved? https://github.com/OpenMW/openmw/pull/1350 (which is the fix as far as I can tell) is still open.

Also, is this really also an issue in vanilla Morrowind? I don't remember having trouble finishing kill quests in vanilla Morrowind, even though I had the habit of eagerly disposing corpses. In OpenMW, I ran into this bug for the second time in a relatively short time. It completely breaks immersion, as it makes quests unfinishable.

#28 Updated by Alexei Dobrohotov 3 months ago

Yes, "Resolved" status means that.

Resolved - A developer has fixed the issue, but the fix has not been reviewed by others and is not included in the official main repository (yet).

from here: https://wiki.openmw.org/index.php?title=Bug_Reporting_Guidelines#Explanation_of_issue_states

#29 Updated by Attila Mika 3 months ago

Alexey Dobrohotov wrote:

Yes, "Resolved" status means that.

Resolved - A developer has fixed the issue, but the fix has not been reviewed by others and is not included in the official main repository (yet).

from here: https://wiki.openmw.org/index.php?title=Bug_Reporting_Guidelines#Explanation_of_issue_states

Ah, I see, thanks!

I Apologize for not reading the docs.

#30 Updated by Alexei Dobrohotov 3 months ago

  • Status changed from Resolved to Closed
  • Operating system changed from Windows to Other

#31 Updated by Dark Locq 3 months ago

Has anyone actually verified this? I'm skeptical that #3528 is legit, unless the problem was caused by a recent build. I did that quest in 0.41.something over a month ago, removed the corpses like I virtually always do, and had no problem returning to Varro to complete the Bloodbath quest.

#32 Updated by Andrei Kortunov 3 months ago

Has anyone actually verified this?

Just look above. We have at least three different bug reports to confirm this issue.

#33 Updated by Dark Locq 3 months ago

So is it intermittent? As I said, I did remove these corpses and did not trigger this bug.

#34 Updated by Randy Davin 3 months ago

maybe this bug doesnt affect the larrius varro quest?

Also available in: Atom PDF