Project

General

Profile

Bug #3451

Feril Salmyn corpse isn't where it is supposed to be

Added by Debian Linuxero 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
06/26/2016
% Done:

100%

Spent time:
Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

I'm playing OpenMw 0.38 on Debian Testing 64 bits, using Morrowind Overhaul.

Playing the quest of Hair Shirt of St. Aralor http://elderscrolls.wikia.com/wiki/Hair_Shirt_of_St._Aralor

I reach the place where it is supposed to be the corpse of Feril Salmyn, outside the Kogohrun stronghold, but it wasn't there.

But, using a detect enchantment spell, it marks this place on map. A place where it is no corpse.

It is like if the corpse was somehow "buried" in the soil.

Sample.omwsave - In Kogohrun stronghold (27.7 MB) Debian Linuxero, 06/27/2016 03:44 PM

Morrowind Patch 1.6.5 Beta (BTB Edit).esm (5.81 MB) Miroslav Remák, 06/28/2016 12:44 PM

History

#1 Updated by Jannik Heller 8 months ago

Maybe it fell through the ground due to a physics glitch. Could you post your save game?

#2 Updated by Debian Linuxero 8 months ago

Hello.

Here it is the save game.

#3 Updated by Miroslav Remák 8 months ago

Using your save game, I can see and interact with the corpse without any issues. Can you try disabling your mods?

#4 Updated by Debian Linuxero 8 months ago

Yes, disabling the mods I can now see the corpse.

Thanks.

P.S. : Is there a way to make this issue to behave correctly with OpenMw + Overhaul 3.0?

#5 Updated by Debian Linuxero 8 months ago

If I load the game with Overhaul's, the player is wearing 459 lbs.

If I load with the official quests plus the 2 + 8 official expansions http://www.elderscrolls.com/morrowind/expansions/ it only wears 414 lbs.

I do really mind losing stuff in the operation.

Is there a console command of any sort to obtain the item and to update the mission log?

#6 Updated by Miroslav Remák 8 months ago

  • Status changed from New to Confirmed

I have tracked this down to "Morrowind Patch 1.6.5 Beta (BTB Edit).esm". This is the error:

error during rendering 'feril salmyn': Enchantment 'hair shirt' not found

Vanilla also complains about the missing enchantment, however it seems to be able to recover from it.

Debian Linuxero wrote:

Is there a console command of any sort to obtain the item and to update the mission log?

Not sure,

player->additem "expensive_shirt_hair" 1
could work, or perhaps even
"feril salmyn"->activate
for remote access to the corpse's inventory if you're still on 0.38 (AFAIK, this is not allowed anymore in 0.39).

#8 Updated by Miroslav Remák 8 months ago

The relevant enchantment is defined in Morrowind.esm with the ID 'hair shirt ' (notice the trailing space).
However, Morrowind Patch 1.6.5 Beta (BTB Edit).esm modifies 'expensive_shirt_hair' to point to a non-existing enchantment 'hair shirt' (without the trailing space).

#9 Updated by Debian Linuxero 8 months ago

I tried various things.

1)Access the invisible corpse's inventory with the "feril salmyn"->activate command.

The item, strangely doesn't had any kind of description. Only an empty black square.

If I put this cloth item myself, then I couldn't move nor rotate. Only open my inventory.
If I quit the shirt, then all becomes normal again. Except that the shirt still doesn't had description.

2)Give the item to the quest giver in Ghostgate.

I gave the item to Uvoo Llaren http://elderscrolls.wikia.com/wiki/Uvoo_Llaren

Apparently all go well. But when I finished the dialog, Uvoo Llaren disappeared.
Disappeared and I couldn't select her anymore.

3)Disabling Morrowind Patch 1.6.5 Beta (BTB Edit).esm

Disabling that patch did that all goes normal, or so it appears.

I can suppose then, that all of this it's not an OpenMW bug.

This bug report can then be closed.

As that patch file, for some reason is pointed as required for Overhaul 3.0, then, I must consult somewhere else how to edit the patch file to add that space trail in the tag of that object.

Thanks for all.

#10 Updated by Debian Linuxero 8 months ago

Just FYI :

I managed to edit the patch file with OpenCS.

Duplicated the record you pointed previously naming it without the space trail.
Then I deleted the old "bad" record.

Verified. Saved. Substituted the original file with this new one, and done!

It works! I can see now the dead Ordinator. The item shows all its properties correctly and I can wear it without issues.

Again. Thanks.

#11 Updated by Miroslav Remák 8 months ago

Debian Linuxero wrote:

This bug report can then be closed.

Even though this was caused by a faulty plugin, I still think OpenMW should handle such situations more gracefully. For example, act as if the item had no enchantment instead of breaking the game.

#12 Updated by Justin Sane 7 months ago

  • Assignee set to Justin Sane
  • Reproducibility changed from Have not tried to Always

#13 Updated by Justin Sane 7 months ago

  • % Done changed from 0 to 100

#14 Updated by Justin Sane 7 months ago

  • Status changed from Confirmed to Resolved

#15 Updated by Miroslav Remák 7 months ago

  • Status changed from Resolved to Closed
  • Target version set to openmw-0.41

#16 Updated by Marc Zinnschlag 7 months ago

Did this one also go into OpenMW 0.40?

#17 Updated by Alexey Dobrokhotov 7 months ago

No, the pull request which fixed this issue was merged right after you merged Aesylwinn's key configuration with master and made openmw-0.40 tag.

Also available in: Atom PDF