Project

General

Profile

Bug #3441

Golden saint always dispelling soul trap / spell priority issue

Added by Martin Zeller over 1 year ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
AI
Target version:
Start date:
06/12/2016
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

If you summon a golden saint in OpenMW, aggro it and cast soul trap on it, it will immediately go and dispel it. Every time.
In the original game, immediate dispel was but one of many options the golden saint could take. In my experience, it usually ignored the spell altogether, or waited a bit before dispelling.

This makes it really annoying to catch souls of golden saints (at least summoned ones, I haven't tried wild ones yet). I usually have to cast soultrap when she's already far down and finish her with a scroll, since I'm not skilled with any weapons and casting a spell takes too long.

If OpenMW wants to mimic the behaviour of the original game (maybe fixing some bugs here and there), I think this should be considered an issue.

See also: #2341, #2760

History

#1 Updated by openmw hardcore over 1 year ago

Martin Zeller wrote:

If you summon a golden saint in OpenMW, aggro it and cast soul trap on it, it will immediately go and dispel it. Every time.
In the original game, immediate dispel was but one of many options the golden saint could take. In my experience, it usually ignored the spell altogether, or waited a bit before dispelling.

This makes it really annoying to catch souls of golden saints (at least summoned ones, I haven't tried wild ones yet). I usually have to cast soultrap when she's already far down and finish her with a scroll, since I'm not skilled with any weapons and casting a spell takes too long.

If OpenMW wants to mimic the behaviour of the original game (maybe fixing some bugs here and there), I think this should be considered an issue.

See also: #2341, #2760

In my opinion, this is not a bug or something to worry about, since Golden Saint have a very large soul, it is necessary that the player require extra skills to obtain the soul. For example, you should use a silence, sound or drain magicka spell on it first... or if you dont use magic, you can bring its health low enough then cast soul trap, or enchant a weapon with cast on strike soul trap, or even drain its fatigue to 0..

#2 Updated by Martin Zeller over 1 year ago

openmw hardcore wrote:

In my opinion, this is not a bug or something to worry about, since Golden Saint have a very large soul, it is necessary that the player require extra skills to obtain the soul.

That's one way to see it. The question is: Does OpenMW want to emulate the original game as closely as possible or will it take liberties like this?
In the former case, this is an issue. In the latter case, it might now be.

I know that combat AI is rather difficult to replicate accurately, so even if this is considered an actual issue, I don't think it will be solved anytime soon. Still, I thought it might be a good idea to file this report anyway to get an “official” statement about it. (Knowing full well that such opinions can change)

#3 Updated by Alexei Dobrohotov 4 months ago

  • Status changed from New to Resolved
  • Target version set to openmw-0.43

#4 Updated by Alexei Dobrohotov 4 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100
  • Operating system changed from Linux to Other

#5 Updated by Alexei Dobrohotov about 2 months ago

  • Assignee set to Andrei Kortunov

Also available in: Atom PDF