Project

General

Profile

Bug #3126

Framerate nosedives when adjusting dialogue window size

Added by August Avatar over 1 year ago. Updated about 2 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
GUI
Target version:
Start date:
01/05/2016
% Done:

100%

Reproducibility:
Always
Operating system:
Windows
Severity:
Normal

Description

Adjusting the size of the dialogue window during any npc conversation will result in a dramatic decrease in fps. It is more noticeable when adjusting in exteriors as the framerate is generally lower, but interiors are affected too: as you can see in the attachment, by simply grabbing one of the window edges and jiggling my mouse around I was able to reduce my fps from 400 down to 5.
Adjusting windows in the right-click menu mode also decreases fps, but not to the same extent.

I cannot reproduce this behavior in vanilla Morrowind; adjusting the window remained smooth even outdoors.

Using OpenMW 0.37.0, Windows 7

screenshot016.png View (1.63 MB) August Avatar, 01/05/2016 03:15 AM

screenshot017.png View (1.62 MB) August Avatar, 01/05/2016 03:15 AM

screenshot065.png View (1.74 MB) August Avatar, 11/10/2016 08:02 AM

screenshot066.png View (1.75 MB) August Avatar, 11/10/2016 08:03 AM

screenshot063.png View (2.15 MB) August Avatar, 11/10/2016 08:23 AM

History

#1 Updated by scrawl . over 1 year ago

  • Priority changed from Normal to Low

#2 Updated by R. D. over 1 year ago

I'm on Windows 7 as well but I can't reproduce this.

Adjusting windows in dialogue or in the right-click menu lowered fps, but not anything near to 5. For example, jiggling the edge of the dialogue window outdoors in Seyda Neen reduced FPS from about 145 to about 110.

Tested the dialogue window in all combinations of Windows Aero on and off, windowed and fullscreen, vsync and no vsync. With vsync on fps stayed at around 60 even while jiggling the dialogue window.

Tested on the .39 release, Windows 7 64bit, no mods, NVIDIA Geforce GTX 660 with driver 364.72.

#3 Updated by R. D. over 1 year ago

Can't reproduce on the release versions of 0.37.0 or 0.38.0, either.

#4 Updated by August Avatar 11 months ago

Playing with latest nightly build (a1c1db467e) and this issue still occurs.

My interest in this issue has been renewed by a recent pull request from MiroslavR (https://bugs.openmw.org/projects/openmw/repository/revisions/d8b506155e6440f2b7cab2d28e34e241637ea449) which resizes the widgets instead of reconstructing them. I'm curious if such a fix could be relevant to the dialogue window.

Regardless, I've included further screenshots with the profiler active to better demonstrate the issue, along with any other dialogue performance oddities I've come across - take note of the line graph in these images.

screenshot066.png is the result of simply grabbing the corner of Fargoth's dialogue box and giving it a little wiggle.

screenshot065.png is what occurs upon giving Fargoth his ring - the game visibly pauses for a moment and this is seen by the small crater on the right end of the graph.

screenshot063.png demonstrates what happens when there has been a large amount of NPC exposition. The large dips seen are from clicking on any conversation topic. The game visibly hiccups when doing this.

Incidentally, the vanilla game did not allow you to scroll all the way back up to the beginning of a long conversation, although I don't think that limitation ought to be replicated in OpenMW if it can be helped.

#5 Updated by scrawl . 7 months ago

  • Status changed from New to Confirmed

#6 Updated by Alexei Dobrohotov about 2 months ago

  • Category changed from Dialogue to GUI
  • Status changed from Confirmed to Closed
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

Also available in: Atom PDF