Project

General

Profile

Feature #3099

Disabling inventory while dragging an item forces you to drop it

Added by Chris Robinson almost 2 years ago. Updated 20 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
GUI
Target version:
Start date:
12/21/2015
% Done:

100%

Severity:
Normal

Description

Marked this issue as a "feature" since I believe vanilla behaves the same way, but it's really annoying and unnecessary that it happens.

If you're dragging an item when the inventory is disabled, you continue to drag the item but can't place it into your inventory window since it's hidden. You can't exit the inventory either until you stop dragging. So the only thing you can do with the item is drop it onto the ground, and for certain items can make it near-impossible to find again.

I've seen this happen mostly with mods that alter Hircine's Ring. Such mods make the ring inhibit werewolf transformations while worn, and re-allows them when it's unequipped. Consequently, if you unequip the ring when you're normally supposed to be transformed, it will cause the transformation to happen right away, which disables your inventory. Since unquipping an item makes you drag it around, you're left dragging the ring without an inventory window, and there's nothing you can do with it but drop it (made worse by the fact that you can't pick items up as a werewolf, and have to remember to come back later to try and find it again).

I think the best way to fix this is to essentially cancel any dragging when the inventory is disabled, so it remains in your inventory. Alternatively, or in addition, you could also allow the inventory to be closed while an item is being dragged, which implicitly cancels the drag and leaves the item in your inventory.


Related issues

Related to OpenMW - Bug #1692: Can't close container when item is "held" Closed 07/25/2014

History

#1 Updated by Marc Zinnschlag almost 2 years ago

  • Target version set to openmw-0.38

Nasty, but okay. After 1.0 we should add a GMST that can disable this behaviour again.

#2 Updated by Marc Zinnschlag almost 2 years ago

  • Target version changed from openmw-0.38 to openmw-0.39

#3 Updated by Miloslav Číž over 1 year ago

How can I simply reproduce this? What exactly does disabled inventory mean and how can I make it disabled?

#4 Updated by Miloslav Číž over 1 year ago

OK, I get it now. Hopefully helpful info to replicate the bug: you can transform to werewolf with "Player->BecomeWerewolf" command, however the console cannot be opened when item is being dragged, but the command might be run from within the game code I guess.

#5 Updated by scrawl . over 1 year ago

Would binding the Escape key to 'cancel drag' fix this issue? That seems to be how most other GUI's do it (just tried it dragging text in the browser or dragging files, Esc cancels the drag).

#6 Updated by Chris Robinson over 1 year ago

Jannik Heller wrote:

Would binding the Escape key to 'cancel drag' fix this issue?

I think it would be a decent work-around, as long as "cancel drag" implies leaving the item in your inventory rather than dropping it. Though it could cause somewhat odd behavior (e.g. open an container, click an item in it once to start dragging, then press Escape to cancel drag which places it in your inventory, since that's where the item effectively is once you start dragging).

#7 Updated by scrawl . over 1 year ago

(e.g. open an container, click an item in it once to start dragging, then press Escape to cancel drag which places it in your inventory, since that's where the item effectively is once you start dragging).

Right, when you start a drag then the item is already in your inventory as far as game logic is concerned. I was going to suggest that 'cancel drag' should put the item back in the container that it came from, but in the pickpocket dialog that's not even possible.

#8 Updated by Chris Robinson over 1 year ago

Jannik Heller wrote:

Right, when you start a drag then the item is already in your inventory as far as game logic is concerned. I was going to suggest that 'cancel drag' should put the item back in the container that it came from, but in the pickpocket dialog that's not even possible.

Yeah, "organic" containers (e.g. plants) can't have things placed in them either, so once it's out of the container, it can't reliably be put back in.

#9 Updated by Marc Zinnschlag over 1 year ago

  • Target version changed from openmw-0.39 to openmw-0.40

#10 Updated by Marc Zinnschlag about 1 year ago

  • Target version changed from openmw-0.40 to openmw-0.41

#11 Updated by Marc Zinnschlag 11 months ago

  • Target version changed from openmw-0.41 to openmw-0.42

#12 Updated by Marc Zinnschlag 6 months ago

  • Target version changed from openmw-0.42 to openmw-0.43

#13 Updated by scrawl . about 1 month ago

  • Target version deleted (openmw-0.43)

#14 Updated by scrawl . 26 days ago

  • Related to Bug #1692: Can't close container when item is "held" added

#15 Updated by Alexei Dobrohotov 22 days ago

  • Status changed from New to Resolved
  • Assignee set to scrawl .
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100

#16 Updated by Alexei Dobrohotov 20 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF