Project

General

Profile

Bug #3049

Drain and Fortify effects are not properly applied on health, magicka and fatigue

Added by Natalie N. almost 2 years ago. Updated 11 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Game Mechanics
Target version:
Start date:
12/01/2015
% Done:

0%

Reproducibility:
Always
Operating system:
Linux
Severity:
Normal

Description

OpenMW 0.37.0 release
Bloodmoon + Tribunal only, no mods.

Constant effect drain Magicka (as from a Slave's bracer) is not properly applied to either the player or NPCs. When applied to the player, there is no effect. When applied to NPCs, Magicka is drained only once, and then no more.

Steps to reproduce:
Load attached save, observe player's current Magicka.
Equip slave bracer, observe player's current Magicka remains unchanged.

Open console, select Thavere Vedrano. Type "getmagicka"
Observe Thavere's Magicka.
Type "additem slave_bracer_left 1"
Exit console. Wait. Open console
Type "getmagicka"
Observe Thavere's Magicka.

DrainMagicka.omwsave (505 KB) Natalie N., 12/01/2015 03:50 AM


Related issues

Duplicated by OpenMW - Bug #2796: Fatigue is 0/0 despite all my stats being 50+ (drain fatigue potion effect issue?(something is fishy)) Rejected 07/25/2015

History

#1 Updated by scrawl . almost 2 years ago

  • Related to Bug #2796: Fatigue is 0/0 despite all my stats being 50+ (drain fatigue potion effect issue?(something is fishy)) added

#2 Updated by Marc Zinnschlag over 1 year ago

  • Target version changed from openmw-0.38 to openmw-0.39

#3 Updated by Marc Zinnschlag over 1 year ago

  • Target version changed from openmw-0.39 to openmw-0.40

#4 Updated by R. D. over 1 year ago

Some notes, just in case.

1. The slave's bracer does affect the player in OpenMW. It might look like it doesn't because of an issue with the maximum magicka being reduced as well. (I believe this is why this bug was linked to bug #2796)

2. Even though the magic effect of the bracers is called "constant effect" and "drain," the magicka being reduced only once is also what happens in vanilla, for both the player and npcs. If you want something that constantly drains a character's magicka, gradually bringing it down to 0, you can use the "damage magicka" enchantment instead.

Sorry if I'm missing something but think this bug report can be closed, actually.

#5 Updated by R. D. over 1 year ago

I should add that I tested on Windows 7 64 bit, as I see the original poster used Linux, just in case there is a potential difference there. I used the nightly (revision d784a77f4c) and no mods.

#6 Updated by Marc Zinnschlag about 1 year ago

  • Target version changed from openmw-0.40 to openmw-0.41

#7 Updated by Marc Zinnschlag 10 months ago

  • Target version changed from openmw-0.41 to openmw-0.42

#8 Updated by R. D. 9 months ago

  • Status changed from New to In Progress
  • Assignee set to R. D.

#9 Updated by R. D. 9 months ago

  • Subject changed from Constant effect Drain Magicka is not properly appiled to Drain and Fortify effects are not properly applied on health, magicka and fatigue

#10 Updated by Marc Zinnschlag 5 months ago

  • Target version changed from openmw-0.42 to openmw-0.43

#11 Updated by Alexei Dobrohotov 5 months ago

  • Status changed from In Progress to Resolved

#12 Updated by Alexei Dobrohotov about 2 months ago

  • Related to deleted (Bug #2796: Fatigue is 0/0 despite all my stats being 50+ (drain fatigue potion effect issue?(something is fishy)))

#13 Updated by Alexei Dobrohotov about 2 months ago

  • Duplicated by Bug #2796: Fatigue is 0/0 despite all my stats being 50+ (drain fatigue potion effect issue?(something is fishy)) added

#14 Updated by scrawl . 11 days ago

  • Target version changed from openmw-0.43 to openmw-1.0

Also available in: Atom PDF