Project

General

Profile

Bug #2841

"Total eclipse" happens if weather settings are not defined.

Added by Denis Smirnov almost 3 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Low
Category:
Configuration
Target version:
Start date:
08/10/2015
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

This one is not really OpenMW's problem, but I find it worth mentioning..
Russian version of Bloodmoon includes a broken Morrowind.ini without settings for BM weather types (Snow and Blizzard). When encountering this weather, MW complains for missing cloud textures, but then works somehow. In OpenMW everything just fades to absolute black until weather changes.
Maybe there should be some fallback for this case? Something like using "Clean" weather settings.

Associated revisions

Revision e4531a69 (diff)
Added by Alexei Dobrohotov 2 months ago

Use middle gray instead of pure black as default fallback color (Fixes #2841)

History

#1 Updated by Alexei Dobrohotov 9 months ago

  • Category set to Configuration

#2 Updated by scrawl . 8 months ago

  • Priority changed from Normal to Low

#3 Updated by Alexei Dobrohotov 2 months ago

  • Status changed from New to Resolved
  • Assignee set to Alexei Dobrohotov
  • Target version set to openmw-0.44
  • % Done changed from 0 to 100
  • Reproducibility changed from Have not tried to Always
  • Operating system changed from Linux to Other

I changed the fallback fallback (sic) color to middle gray instead of pure black.

#4 Updated by Alexei Dobrohotov 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF