Project

General

Profile

Feature #2707

OpenMW: make (long) hair flow over the torso instead of into the torso

Added by Who Knows over 2 years ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/18/2015
% Done:

0%

Severity:
Normal

Description

Right now it "enters" the upper back and does not seldom reappear lower again.

Maybe the hair can be segmented and the position of the segments be calculated by taking the shape of the torso and arms/shoulders as well as other segments into account. This might be extended to make it work with cloth like coats, shirts... too. Maybe the algotithm can be made independed from what the (N)PC is wearing by using the shape of all together and rendering the hair then. The use of helms and such would be a special case.

History

#1 Updated by scrawl . about 1 month ago

  • Status changed from New to Rejected
  • Target version deleted (openmw-future)

Rejecting as not a concrete request, use the forum to discuss.

#2 Updated by Who Knows about 1 month ago

How is "make (long) hair flow over the torso instead of into the torso" not a concrete request?!

I'll use other words then:
Fix the graphical problem which is that hair cuts through metal and flesh.

I do not see how this has to be discussed. Either you think it is not worth to be implemented and that you aren't going to implement it at any time - that's just how you decided now - or you leave that option available. Asking me to get enough people to support this will predictably result in a failure.

Please reopen!

Now, completely w/o sarcasm, are you interested in getting feature request (like this) at all? If it's rather important to kill feature requests from the database I will leave it be.

#3 Updated by Chris Robinson about 1 month ago

Who Knows wrote:

How is "make (long) hair flow over the torso instead of into the torso" not a concrete request?!

Because it suggests a result without anything to achieve said result. [i]How[/i] would you prevent the hair from cutting into the torso? You first have to figure out what the problem is that causes it to happen, then figure out ways to reasonably stop it from happening. That's what the forum would be for, to work out and discuss what can actually be done rather than a nebulous "let's make it better".

And FWIW, your suggestion to segment the hair and position the segments relative to the body is called "skinning" and it falls into the domain of the content files (the hair meshes), not the engine. Maybe the engine would need to add support for skinned hair meshes (I don't know if it currently does), but that's not what this feature request says. There's also other ways to deal with it too, such as real-time "cloth" and hair physics. But it would still need modified meshes which is out of the scope of the engine.

#4 Updated by scrawl . about 1 month ago

Rejected here doesn't mean such feature will not be possible - just needs to go to the forum for discussion first on how it should be done (like Chris said, there are many options). The bugtracker is meant to be used as a way for developers to find something to work on, hence why we (recently decided to) reject things that are too vague, too broad or otherwise not ready for implementation. It's better to post such suggestions on the forum, where users and developers alike can discuss (vs. the bugtracker mostly just seen by developers).

Btw, I'm not bashing this request in particular, there are many more to reject that I just haven't gotten to yet. We could collect everything that's rejected into a forum post so nothing gets lost and if anyone interested they can pick up the discussion there.

#5 Updated by Who Knows about 1 month ago

Chris Robinson wrote:

Who Knows wrote:

How is "make (long) hair flow over the torso instead of into the torso" not a concrete request?!

Because it suggests a result without anything to achieve said result. [i]How[/i] would you prevent the hair from cutting into the torso? You first have to figure out what the problem is that causes it to happen, then figure out ways to reasonably stop it from happening. That's what the forum would be for, to work out and discuss what can actually be done rather than a nebulous "let's make it better".

My report did not contain a nebulous "make it better" but that hair should not cut into matter like metal or flesh. I even supplied concrete idea - apparently not a good one but the evaluation can only made by the devs.

for the record:
I am no developer, neither do I know what openscenegraph or the physics lib is capable of - I have no clue how OpenMW/OpenCS works internally.
If you demand a solution with my bug reports / feature requests you may want to reject all my reports because I almost never did supply code or a working concept.

Please tell me the criteria so that I know whether I create a report xor a forum entry!

#6 Updated by Who Knows about 1 month ago

scrawl . wrote:

Rejected here doesn't mean such feature will not be possible - just needs to go to the forum for discussion first on how it should be done (like Chris said, there are many options). The bugtracker is meant to be used as a way for developers to find something to work on, hence why we (recently decided to) reject things that are too vague, too broad or otherwise not ready for implementation. It's better to post such suggestions on the forum, where users and developers alike can discuss (vs. the bugtracker mostly just seen by developers).

Btw, I'm not bashing this request in particular, there are many more to reject that I just haven't gotten to yet. We could collect everything that's rejected into a forum post so nothing gets lost and if anyone interested they can pick up the discussion there.

Alright, that's something concrete. I'll try to get what's complex and use the forum then. Thx for explaining!

Also available in: Atom PDF