Project

General

Profile

Feature #2554

OpenMW-CS: Modifying an object in the cell view should trigger the instances table to scroll to the corresponding record

Added by Who Knows over 2 years ago. Updated 11 months ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
Editor
Target version:
Start date:
05/15/2015
% Done:

0%

Severity:
Normal

Description

prerequisite: the instances table is open

History

#1 Updated by cc 9cii over 2 years ago

This is a bug, not a feature request. However, all the 3D editing code will be removed soon, so it is probably not worth fixing.

#2 Updated by cc 9cii over 2 years ago

  • Tracker changed from Feature to Bug
  • Category set to Editor
  • Status changed from New to Rejected
  • Reproducibility set to Have not tried
  • Operating system set to Other

#3 Updated by cc 9cii over 2 years ago

Just for the record, the instance table does get updated, but not the cell. I guess it is a philosophical question. Technically the object instance co-ordinates change, not the cell itself. But it may be confusing to the end-user. That question is worth posing on the forum, especially @Zini.

#4 Updated by Who Knows over 2 years ago

Sorry, I probably didn't explain properly. :-\

When you are in the cell view you can move an instance (tree, plant...) by using the right mouse button. It would be nice if the entry of that instance would come into view in the instances table. It would be even better if this worked with just clicking on the object in the cell view (w/o moving it).

1. open cell table and instances table
2. in the cell table right click on an entry and select "view"
3. now move an object ("instance") in the cell view "window" by dragging it with the right mouse button
4. ---> what I'm asking for: the table displays now the row of that instance

As it is now you have no clue what instance (OID) you just moved...

Why I need that:
I want to edit the position of an object ("instance"), lets say a rock. I don't know it's ID but where it is, so I open the cell view and navigate there (WASD). In the cell view you can only move an object in height and the x-axis. It would be nice if I now could change other parameters or adjust the instance precisely by changing values in the instances table.

#5 Updated by cc 9cii over 2 years ago

  • Subject changed from Editor: touching an object in the cell view should mark its entry in the instances table to Editor: Modifying an object in the cell view should trigger the instances table to scroll to the corresponding record
  • Status changed from Rejected to Confirmed

Not sure if this is feasible...

#6 Updated by cc 9cii over 2 years ago

  • Tracker changed from Bug to Feature

Based on the clarification this is indeed a feature request.

#7 Updated by Who Knows over 2 years ago

Perfect! :)
Maybe shift-click/strg-click or ... in the call view could make the table scroll there as well, not just modifying. Thanks

#8 Updated by cc 9cii over 2 years ago

Don't understand... Did you want the cell table jump to the object instance's cell?

#9 Updated by cc 9cii over 2 years ago

  • Assignee set to cc 9cii
  • Target version set to openmw-0.37
  • % Done changed from 0 to 100

#10 Updated by Who Knows over 2 years ago

cc 9cii wrote:

Don't understand... Did you want the cell table jump to the object instance's cell?

No. Please, maybe this is a better description:

1. open the instances subview, for this example lets assume entries having the IDs A40 to A50 are visible now
2. open the cell subview
3. select an exterior cell in the cell subview and open the pictorial "view" of that cell (view - not like "table" in OpenMW, but like picture with forms and colors)
4. now use the right mouse to move a rock in that pictorial view

What I'd like to have is, that - as soon as I moved the rock - the instance table shows the entry of that instance (rock, placed in the MW game world). So this feature would show me the row in the instances table for the rock that I just moved. The ID in the instances table may be C120, so the instances tables wouldn't show A40-A50 anymore but C120-C130.

Sorry, I am no native english speaker. I hope this helped. :\

What I asked for in my preceeding comment was to have a way to get the instance row as described above with the difference that just "marking"/"touching" the rock would be enough to make the row of that rock appear in the instances table.

#11 Updated by cc 9cii over 2 years ago

The second part of your request needs a feature that is about to be obsolete (with osg port). I will think about it, but it will have to be separate to this ticket.

#12 Updated by cc 9cii over 2 years ago

  • Assignee deleted (cc 9cii)
  • Target version deleted (openmw-0.37)
  • % Done changed from 100 to 0

PR closed since it will need to be redone with osg.

#13 Updated by Jeffrey Haines 11 months ago

  • Subject changed from Editor: Modifying an object in the cell view should trigger the instances table to scroll to the corresponding record to OpenMW-CS: Modifying an object in the cell view should trigger the instances table to scroll to the corresponding record
  • Target version set to openmw-cs-1.0

Unify all editor ticket subjects to start with "OpenMW-CS:"

Also available in: Atom PDF