Project

General

Profile

Bug #2489

Keeping map open not persisted between saves

Added by Matthew Smithson over 2 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
GUI
Target version:
Start date:
04/17/2015
% Done:

0%

Reproducibility:
Always
Operating system:
Windows
Severity:
Normal

Description

I am running OpenMW .351 on Windows XP SP3.

I like to pin the map to the upper right corner of the screen (right click, in the map box in the upper right, click the button in the upper right corner of it) so I can see where I'm going. In the original Morrowind engine, this would be persisted between my saves but in OpenMW it is now.

Steps to simulate:
1.) Start a game, right click to bring up the inventory/magic/etc... screen.
2.) Click the button in the upper right of the map window. Now when you go back to your game, the map will always be open.
3.) Save your game and reload it - the map is no longer pinned. This probably applies to the other screens (inventory, magicka) as well.


Related issues

Related to OpenMW - Feature #2834: have openMW's UI remember what menu items were 'pinned' across boots. Closed 08/08/2015
Duplicated by OpenMW - Feature #3659: Save state of map window and restore it on loading Rejected 12/13/2016

Associated revisions

Revision 95ce7637 (diff)
Added by Andrei Kortunov 7 months ago

Adds persisted pin (feature #2834, bug #2489)

History

#1 Updated by Matthew Smithson over 2 years ago

One interesting and related note is that this setting (as well as the setting to keep other right click windows open always) is persisted when you start a new game without restarting OpenMW. If you choose to keep all the right click windows open and start a new game, they will all be open in the new game, blocking the entire screen and since you don't have the ability to close them yet, you are stuck - but it is kind of interesting to see your "stats" before you set them.

This setting should be persisted in the save files and not stored as a global setting as long as the game is running - ie new games should start with all screens hidden and the showing of screens should be stored in the save file.

#2 Updated by scrawl . over 2 years ago

  • Related to Feature #2834: have openMW's UI remember what menu items were 'pinned' across boots. added

#3 Updated by Miroslav Remák 11 months ago

  • Duplicated by Feature #3659: Save state of map window and restore it on loading added

#4 Updated by Alexei Dobrohotov 7 months ago

  • Status changed from New to Resolved
  • Target version set to openmw-0.42

#5 Updated by Marc Zinnschlag 7 months ago

  • Target version changed from openmw-0.42 to openmw-0.43

#6 Updated by Alexei Dobrohotov 7 months ago

  • Status changed from Resolved to Closed

Resolved by Kortunov with pull request 1253

#7 Updated by Alexei Dobrohotov 4 months ago

  • Assignee set to Andrei Kortunov

Also available in: Atom PDF