Project

General

Profile

Bug #2405

Maximum distance for guards attacking hostile creatures is incorrect

Added by scrawl . over 2 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Category:
AI
Target version:
Start date:
02/27/2015
% Done:

0%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

The maximum distance for being arrested on sight (e.g. with setpccrimelevel, 3000) is much larger than in vanilla MW.

History

#1 Updated by Andrei Kortunov 2 months ago

  • Status changed from New to Confirmed
  • Reproducibility changed from Have not tried to Always

The same thing when a guard tries to protect a player from hostile creatures. We just process all actors in AI processing distance.

Looks like both cases are capped by fAlarmRadius GMST in Morrowind (2000 units by default, it is near 30 meters).

#2 Updated by Andrei Kortunov 2 months ago

  • Status changed from Confirmed to Feedback needed

Hmm... It seems changing of fAlarmRadius actually affects arrest distance in OpenMW.
The "arrest" case works fine for me, but "protect" case uses AI processing distance.

#3 Updated by scrawl . 2 months ago

  • Subject changed from Maximum distance for being arrested on sight is incorrect to Maximum distance for guards attacking hostile creatures is incorrect

Very possible this was fixed since the report. Let's make it about the remaining thing then.

#4 Updated by Andrei Kortunov 2 months ago

  • Category set to AI
  • Status changed from Feedback needed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.43
  • Operating system changed from Linux to Other

#5 Updated by Alexei Dobrohotov 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF