Project

General

Profile

Bug #1990

Sunrise/sunset not set correct

Added by Gram Blosh over 3 years ago. Updated 13 days ago.

Status:
Resolved
Priority:
Normal
Category:
Game Mechanics
Target version:
Start date:
10/08/2014
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Minor

Description

In OpenMW the sun rises at about 6 am and go does at 6 pm, in original Morrowind this is more like 8 am and 8 pm.

Version: 0.32 x64 on Win7
Morrowind.esm: German localization

History

#1 Updated by Alexei Dobrohotov over 1 year ago

Morrowind.ini default values for sunrise time and sunset time are 6 and 18 (hours) respectively, and according to INI status the Sunrise/Sunset time are "implemented".

Perhaps in original engine the values are hardcoded or something.

#2 Updated by R. D. over 1 year ago

They aren't hardcoded. I just tried and they do have an effect. It does seem to be hardcoded that when midnight passes it starts over with a night sky, though.

I can confirm, though, that the sky appearance seems to be a little different, like it's an hour off or something.

#3 Updated by Andrei Kortunov 8 months ago

Sunset/sunrise settings:

fallback=Weather_Sunrise_Time,6
fallback=Weather_Sunset_Time,18
fallback=Weather_Sunrise_Duration,2
fallback=Weather_Sunset_Duration,2

I do not know, what these settings are supposed to do:

fallback=Weather_Sun_Pre-Sunrise_Time,0
fallback=Weather_Sun_Post-Sunrise_Time,0
fallback=Weather_Sun_Pre-Sunset_Time,1    ; looks like only this settings is in use
fallback=Weather_Sun_Post-Sunset_Time,1.25
fallback=Weather_Sky_Pre-Sunrise_Time,.5
fallback=Weather_Sky_Post-Sunrise_Time,1
fallback=Weather_Sky_Pre-Sunset_Time,1.5
fallback=Weather_Sky_Post-Sunset_Time,.5

but in seems these settings are related to sun and sky behaviour.

#4 Updated by Alexei Dobrohotov 8 months ago

  • Status changed from New to Confirmed

Apparently it's OpenMW that has sunset and sunrise time kind of hardcoded! Relevant todo here.

#5 Updated by Alexei Dobrohotov 7 months ago

  • Category set to Configuration
  • Operating system changed from Linux to Other

#6 Updated by scrawl . 7 months ago

  • Category changed from Configuration to Game Mechanics

#7 Updated by Alexei Dobrohotov 5 months ago

  • Target version set to openmw-1.0

#8 Updated by Andrei Kortunov about 1 month ago

About OP problem: in my testing sun rised at about 6 am and went down at 8 pm in both OpenMW and Morrowind.
I have these settings:

fallback=Weather_Sunrise_Time,6
fallback=Weather_Sunset_Time,18
fallback=Weather_Sunrise_Duration,2
fallback=Weather_Sunset_Duration,2

So sun becomes visible after the Weather_Sunrise_Time (6:00) and becomes not visible after Weather_Sunset_Time+Weather_Sunset_Duration (20:00).
Can anyone reproduce the bug with sunrise/sunset time?

#9 Updated by Andrei Kortunov 13 days ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Andrei Kortunov
  • Target version changed from openmw-1.0 to openmw-0.44
  • % Done changed from 0 to 100

Also available in: Atom PDF