Project

General

Profile

Bug #1987

Some glyphs are not supported

Added by Mordicus Mordicus over 3 years ago. Updated 13 days ago.

Status:
Closed
Priority:
Normal
Category:
GUI
Target version:
Start date:
10/07/2014
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

There is a minor bug with OpenMW 0.32 and French diaologue menus. The "goodbye" menu on the botton displays unwanted "?" signs. Please check the attached screenshot.

Win7 ultimate 64bits French version.

Clipboard 1.jpg View (72 KB) Mordicus Mordicus, 10/07/2014 11:47 AM

openmw.cfg (30.4 KB) Mordicus Mordicus, 10/13/2014 11:37 AM

Bug.jpg View - Edited Withershins book: "en dash" and "double quotation mark" bug (735 KB) Andrei Kortunov, 07/20/2017 07:58 AM

PC_bug.jpg View - Province Cyrodiil: quotation mark bug (1.06 MB) Andrei Kortunov, 07/20/2017 08:04 AM

Associated revisions

Revision 1aa3ed0c (diff)
Added by Alexei Dobrohotov 22 days ago

Font loader fallback character reorganization (fixes #1987)

History

#1 Updated by scrawl . over 3 years ago

What mods are you using? The font looks like Better Dialogue Font. Any other mods in use?

#2 Updated by Mordicus Mordicus over 3 years ago

Yes, I am using Hrnchamd's Better Dialogue Font 1.1. Do I need to uninstall it and check again?

#3 Updated by scrawl . over 3 years ago

Do I need to uninstall it and check again?

Yes, that would be helpful. Also please attach your user openmw.cfg file (https://wiki.openmw.org/index.php?title=Paths)

#4 Updated by Mordicus Mordicus over 3 years ago

I've uninstalled Better Dialogue Font mod, but the small bug is still here.
You will find my openmw.cfg file attached.

#5 Updated by scrawl . over 3 years ago

Please disable all ESM files except for Morrowind.esm, Tribunal.esm and Bloodmoon.esm and see if it's fixed then. My guess is PNOG.esm causing it, as I now recall a previous report #673.

This may not be an issue in vanilla since it just ignores invalid characters, while OpenMW displays them as a question mark for warning purposes.

#6 Updated by Mordicus Mordicus over 3 years ago

I confirm that the problem comes from PNOG.esm (the very popular unofficial patch for Morrowind French version). Once the PNOG.esm is disabled, the problem is gone! No problem are caused by others .esm and plugins I've tried.

#7 Updated by scrawl . over 3 years ago

Can we alert the author of the mod about this problem then?

#8 Updated by Yann GOUY over 3 years ago

I've done some research about the PNOG.esm.

thanks to official final (http://forum.wiwiland.net/index.php?/topic/50739-quest-ce-que-le-pno-de-wiwiland/),
it seems that the 'invalid' characters are introduced by the french TESCS:

"Le PNO corrige tout ce qui est accessible grâce au TESCS (l'outil de création et modification du jeu fourni par Bethesda) et grâce aux outils de modification de ressources (comme Blender, Gimp...etc.)."

meaning:
"The PNO corrects everything that is accessible by the TESCS (the tool of creation and modification of the game given by Bethesda) and by ressouce modification tools (such as Blender, Gimp... etc)"

So, it seems openmw shall handle those characters.

#9 Updated by Andrei Kortunov 9 months ago

A list of unsupported characters are much larger.
For example, "en dash" and quotation marks are not supported, take a look at attached screenshots.

#10 Updated by Alexei Dobrohotov 7 months ago

  • Subject changed from Minor bug with French menus to Some glyphs are not supported
  • Category set to GUI

#11 Updated by Alexei Dobrohotov 7 months ago

  • Status changed from New to Confirmed

#12 Updated by Andrei Kortunov 5 months ago

Looks like the default OpenMW font (DejaVuLGCSansMono.ttf, I suppose) does not have some glyphs, or these glyphs are binded to wrong characters (CTRL+C / CTRL+V from edit boxes works fine).
Can we modify the font to handle more characters?

#13 Updated by Andrei Kortunov 5 months ago

  • Operating system changed from Windows to Other

#14 Updated by Andrei Kortunov 5 months ago

Related forum topic.

#15 Updated by Alexei Dobrohotov 25 days ago

Apparently there are some hacks OpenMW uses to "support" these glyphs with Magic Cards font, but they only work with Win-1252 encoding. They should probably be extended to all encodings game can use that are not Unicode.

#16 Updated by Alexei Dobrohotov 23 days ago

The issue from the report comes from the edit of sGoodbye: the value of that GMST was changed to "Au‡‡‡revoir" in french unofficial patch. This character is called diesis and has 0x2020 code, and the hacks OpenMW uses already take that character in account, replacing it with a plus sign. Or at least they supposed to. From my testing this doesn't work, so it looks like they never worked ever since their implementation four years ago.

#17 Updated by Alexei Dobrohotov 23 days ago

Wait, no. They're supposed to work. Diesis is simply not replaced.

#18 Updated by Alexei Dobrohotov 23 days ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Alexei Dobrohotov
  • Target version set to openmw-0.44

It has 0x2021 code.

#19 Updated by Andrei Kortunov 22 days ago

I wonder what these "double dagger" characters supposed to do in vanilla game. "Au+++revoir" is a bit mess too.

#20 Updated by Andrei Kortunov 22 days ago

"Au+++revoir" is a bit mess too.

That's because U+2021 should be replaced not for + sign, but for 216 glyph. Default Latin font does not have this glyph, so these characters will not be displayed.

#21 Updated by Alexei Dobrohotov 13 days ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF