Project

General

Profile

Bug #1901

Spiral towers with people in them are impassable

Added by Austin Pitts about 3 years ago. Updated about 2 months ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
Physics
Target version:
Start date:
09/09/2014
% Done:

0%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

The way our movement works we cant pass people in the narrow towers. checked on vanilla can walk past them most of time

Screenshot_20170713_113648.jpg View (663 KB) Andrei Kortunov, 07/13/2017 09:39 AM

Screenshot_20170713_113257.png View (2.33 MB) Andrei Kortunov, 07/13/2017 09:39 AM

Screenshot_20170713_123304.jpg View (651 KB) Andrei Kortunov, 07/13/2017 10:37 AM


Related issues

Related to OpenMW - Bug #1806: PC is stopped when walking along inclined wall or swimming along bank Confirmed 08/12/2014

History

#1 Updated by scrawl . about 3 years ago

  • Category set to Physics

#2 Updated by scrawl . over 2 years ago

  • Status changed from New to Confirmed

#3 Updated by Alexei Dobrohotov 9 months ago

  • Duplicates Bug #1806: PC is stopped when walking along inclined wall or swimming along bank added

#4 Updated by Alexei Dobrohotov 9 months ago

  • Status changed from Confirmed to Rejected

#5 Updated by R. D. 9 months ago

Seems to me the other bug is about slopes and this one about collision with NPCs, so I don't think it's a duplicate.

Collisions have changed with recent code updates, but I find I can still get by an NPC in the spiral staircase in the original engine when I can't get by in OpenMW.

#6 Updated by scrawl . 9 months ago

  • Status changed from Rejected to Confirmed

#7 Updated by Alexei Dobrohotov 9 months ago

  • Duplicates deleted (Bug #1806: PC is stopped when walking along inclined wall or swimming along bank)

#8 Updated by Alexei Dobrohotov 9 months ago

  • Related to Bug #1806: PC is stopped when walking along inclined wall or swimming along bank added

#9 Updated by Andrei Kortunov 4 months ago

Just tested an original game. It seems player in Morrowind does not have a collision box and can move inside another actors collision boxes. A collision based by mesh dimensions, maybe?

#10 Updated by Andrei Kortunov 4 months ago

Sorry for being unprecise. Morrowind does not show a player collison box if "tcb" was activated from 1st-person view.

But actors (or player at least) still can walk in another actors collision boxes, see the screenshot.

#11 Updated by Alexei Dobrohotov 2 months ago

  • Subject changed from Spiral towers with people in them are unpassable. to Spiral towers with people in them are impassable
  • Target version set to openmw-1.0
  • Reproducibility changed from Have not tried to Always
  • Operating system changed from Linux to Other

#12 Updated by Andrei Kortunov about 2 months ago

Additional testing results:
1) It seems Morrowind uses a mesh dimesions for an "actor-actor" collisions in interiors, but uses collision boxes in exteriors
2) A player does not collide with small creatures (such as rats and scribs) in both exteriors and interiors.

Looks like Bethesda's programmers used a couple of hacks to workaround some collision issues.
Should we replicate this behaviour?

#13 Updated by Andrei Kortunov about 2 months ago

Can we just use mesh dimensions for any actor collision in interiors? Maybe this trick can help us to avoid stucks in mines, narrow towers, etc.

#14 Updated by Andrei Kortunov about 2 months ago

Can we just use mesh dimensions for any actor collision in interiors?

From the other side, this change can break a range combat and magic.
So we can change only "actor-actor" collisions.

Also available in: Atom PDF