Project

General

Profile

Bug #1751

Birthsign gives Endurance over 100

Added by Gordon Hales about 3 years ago. Updated 10 days ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
Game Mechanics
Target version:
Start date:
08/03/2014
% Done:

0%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

Attributes in stock Morrowind are capped at 100. If you choose the Lady as your Birthsign, you start with +25 Endurance and Personality, but can still only max out at 100.

As per the attached screenshot, OpenMW let me increase my Endurance to 105. The last time I leveled, the dialogue let me add a 5 point bonus to an Endurance of 75, for a total of 80. Note that the stats menu shows that my Endurance is highlighted (magically enhanced) by the +25 of the Lady. Note also that I selected Strength and Endurance as my favourite attributes, but those buffs don't show as highlighted.

EnduranceOver100.png View (1.85 MB) Gordon Hales, 08/03/2014 07:50 PM


Related issues

Related to OpenMW - Bug #1816: Fortify attribute effects don't affect skill training cap Confirmed 08/16/2014
Duplicated by OpenMW - Bug #2049: Fortify Effects of signs should not be indicated in Attribute window Rejected 10/22/2014
Duplicated by OpenMW - Bug #3636: The Lady sign Rejected 11/23/2016
Duplicated by OpenMW - Bug #3760: Training not working Rejected 02/19/2017

History

#1 Updated by scrawl . about 3 years ago

Working as intended. Leveling up uses the Base value of the attribute, not the fortified one. The birthsign gives you a permanent fortify spell.

#2 Updated by Gordon Hales about 3 years ago

OK. It's no big deal, but that's not how stock Morrowind works.

#3 Updated by scrawl . about 3 years ago

I see. Personally, I would prefer the openmw behaviour. If abilities affect the base stat, then they are useless in the late game.

Usually I wouldn't argue about it and just implement what vanilla does. However in this case it would result in unclean code and special cases all over the place. Not sure yet if I want to do that.

#4 Updated by Stuart Moore about 3 years ago

Are there any instances where fixing this behaviour may have unintended consequences (i.e., Morrowind relying on said behaviour)?

#5 Updated by Gordon Hales about 3 years ago

None that I know of, other than the game balance issue. Health goes up 1/10th your Endurance on level up, so maxing it out early turns you into a bit of a tank. Letting you go past 100 would just make you more bullet proof. I think they nerfed the Lady in Oblivion to +10, because of this.

#6 Updated by scrawl . about 3 years ago

None that I know of, other than the game balance issue. Health goes up 1/10th your Endurance on level up, so maxing it out early turns you into a bit of a tank. Letting you go past 100 would just make you more bullet proof.

Actually, the opposite would be the case here. The levelup endurance health bonus uses the Base endurance, meaning birthsign abilities won't add to it in OpenMW and you'll have less health.

#7 Updated by Gordon Hales about 3 years ago

That works out for the best, I think.

#8 Updated by Arthur Moore about 3 years ago

While I'm ok with the way the code currently works another option is to have the birth signs directly modify the base stats at character creation, and have the enchantment it bestows as cosmetic. If they're set as enchantments in morrowind.esm then I wouldn't mess with them though.

#9 Updated by Cal Urban about 3 years ago

I think that if possible the birthsign effects should be kept as in vanilla. I assume this issue also effects the steed/lovers?

#10 Updated by rot tor about 3 years ago

Not a fan of how that makes the Lady birthsign almost mandatory for non-atronachs, but the main reason it is chosen by MW players is likely the health bonus on level-ups. Although birthsigns appear in the magic effects list in vanilla they do affect base stats there (and the value is displayed normally, not in white as if fortified)

Note that base stat values are also relevant to vanilla faction rank requirements (eg Fighters Guild and House Redoran for Endurance, guess Hlaalu for personality, etc.) - even if those requirements are low (30-35) and easily met, it would be bad for birthsign bonuses not to apply there.

#11 Updated by scrawl . almost 3 years ago

  • Duplicated by Bug #2049: Fortify Effects of signs should not be indicated in Attribute window added

#12 Updated by scrawl . over 2 years ago

  • Target version set to openmw-0.41

#13 Updated by scrawl . over 2 years ago

  • Status changed from New to Confirmed

#14 Updated by Erich Z. over 2 years ago

In all versions of MW the Endurance bonus from birthsigns is calculated in for the levelup bonus.

#15 Updated by The Pop000100 over 2 years ago

even though this is a deviation from vanilla I would like this to be a optional feature.
spectaclesofdoom wrote a script doing this for vanilla this is the only place that I can think of this interfering with a mod maybe GCD.

PS the birthsign level up remover is included in BTB's Game Improvements

#16 Updated by Brad Baago almost 2 years ago

The openmw implementation is better and I think we should keep it. A lot of people think its to powerful because they believe it affects health gain per level but as stated by someone else it does not. So having endurance 125 really only gives you more fatigue. And personality 125 is useful but not really game changing as musk and other enhancers are easy to come by.

#17 Updated by Michael Gerhard almost 2 years ago

Yes, I also like openmw's implementation. Also with Vampires. It's more consistent.

#18 Updated by Gordon Hales over 1 year ago

I just found a further complication for this bug.

I was not allowed to advance in the Temple to Curate (minimum Personality 31) because my Pers was too low. It was 55, including +25 from the Lady. Apparently, openMW doesn't include birthsigns in calculating requirements for faction advances. I believe that Morrowind does.

#19 Updated by Miroslav Remák 10 months ago

  • Duplicated by Bug #3636: The Lady sign added

#20 Updated by Marc Zinnschlag 10 months ago

  • Target version changed from openmw-0.41 to openmw-0.42

#21 Updated by scrawl . 7 months ago

  • Duplicated by Bug #3760: Training not working added

#22 Updated by rot tor 7 months ago

A couple of the original quirks of abilities, which may or may not be relevant:

Unlike openMW, the MW engine does not "update" magnitudes from the original spell objects, and both constant effect enchantments and ability effects act more like a permanent spell that has already been cast on the player. Meaning that if a new plugin is added that changes the magnitude of an ability-type spell effect, the magnitude that affected the player in the savegame remains the same (unless it's removed and re-added),

From MSFD: abilities can be added by AddSpell or removed by RemoveSpell, but if the ability came from character generation, it can't be re-added afterwards (ironically the reverse of what was reported in Bug #2685 ). It seems the engine had some exception for abilities applied through chargen, but that affecting base attributes happened regardless of that.

#23 Updated by Marc Zinnschlag 5 months ago

  • Category set to Game Mechanics
  • Target version changed from openmw-0.42 to openmw-0.43

#24 Updated by Alexei Dobrohotov 4 months ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100
  • Reproducibility changed from Have not tried to Always
  • Operating system changed from Linux to Other

#26 Updated by R. D. about 2 months ago

Is that PR the one you intended to link to? Right now it's only for health, magicka and fatigue.

It did also have some fixes for draining and fortifying attributes, which has since been removed to simplify the PR, but I'm not sure if it would have fixed this issue.

#27 Updated by R. D. about 2 months ago

#28 Updated by Andrei Kortunov about 2 months ago

  • Status changed from Resolved to Confirmed
  • % Done changed from 100 to 0

#29 Updated by Alexei Dobrohotov about 2 months ago

  • Related to Bug #1816: Fortify attribute effects don't affect skill training cap added

#30 Updated by scrawl . 10 days ago

  • Target version changed from openmw-0.43 to openmw-1.0

Also available in: Atom PDF