Project

General

Profile

Bug #1452

autosave is not executed when waiting

Added by Lord Berandas over 3 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
General
Target version:
Start date:
06/09/2014
% Done:

100%

Reproducibility:
Always
Operating system:
Other
Severity:
Normal

Description

I broke my game somehow, when waiting it Caldera MG the autosave is not executed, but it was working okay on my previous playthroughs. Perhaps it has something to do with quest scripts or whatever, I'll describe what I did before.

I took the first and second quest at Balmora FG, completed them, got advanced, leveled in the bed to second level (autosave was working), took the third quest, teleported to Caldera MG where I noticed.

Sleeping in bed and resting until healed saves the game okay. It also occurs in any other cell or exterior, so it's not cell related, loading the game changes nothing.
I'm including the savegame. (hope it's the correct one, since they are just numbered and I don't know what is what.)

2.rar (1.58 MB) Lord Berandas, 06/09/2014 05:13 PM


Related issues

Duplicated by OpenMW - Bug #3828: Autosave conditions differ from vanilla Rejected 04/15/2017

Associated revisions

Revision c542ae68 (diff)
Added by Andrei Kortunov about 1 month ago

Create autosave when waiting (bug #1452)

History

#1 Updated by scrawl . over 3 years ago

  • Status changed from New to Rejected
  • Target version deleted (openmw-0.41)

Intended behaviour. Resting autosaves because it is potentially dangerous (region levelled list creature, DB assassins, etc). Waiting however is totally harmless.

#2 Updated by scrawl . over 3 years ago

On top of that, the text in the settings window actually says "Save when resting" (in my translation, anyway).

#3 Updated by Lord Berandas over 3 years ago

I see, then I misunderstood that, my mistake, sorry :)

#4 Updated by Alexander Nadeau 10 months ago

In vanilla (at least the current up-to-date steam version, without MCP) "wait" does autosave the game. In OpenMW 0.40 it doesn't, at least by default (I haven't checked for hidden settings).

#5 Updated by Miroslav Remák 5 months ago

  • Duplicated by Bug #3828: Autosave conditions differ from vanilla added

#6 Updated by Andrei Kortunov 5 months ago

Should we keep vanilla behaviour, or reject this bug?

#7 Updated by Andrei Kortunov 5 months ago

Oops, I had not noticed the bug is already rejected. Sorry.

#8 Updated by scrawl . about 1 month ago

  • Status changed from Rejected to New

Reopening because I changed my mind. With such very minor issues we should go for the vanilla behavior, just so people don't keep asking why we did it differently.

#9 Updated by Andrei Kortunov about 1 month ago

  • Status changed from New to Resolved
  • Assignee set to Andrei Kortunov
  • Target version set to openmw-0.43
  • % Done changed from 0 to 100
  • Reproducibility changed from Have not tried to Always
  • Operating system changed from Windows to Other

#10 Updated by Alexei Dobrohotov about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF